using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+:(?=.*$)";
string input = @"El Chico Mexican Restaurant
(555-555-5555)
Server: Mike
Drk: Water APT: Chip Salse Entrée: Grando Chicken Dessert: Pie";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}