#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+)\h+(\S+)\h+(\w+(?:\h\w+)*(?:\h*\([^)]+\)(?:\h\w+)?)?)(?:\h{2,}(\S+))?$"
Local $sString = "SIG.SND.SERV ZOS FD MCA LPAR (MCA - NDMSRV LOCAL)" & @CRLF & _
"ADC1 ZOS AMEX SSL" & @CRLF & _
"ADEPTRA.GB1.PROD LINUX FICO (ADEPTRA) LTD TLS" & @CRLF & _
"ADEPTRA.GB2.CQA LINUX FICO (ADEPTRA) LTD TLS" & @CRLF & _
"AIX.EG3C UNIX BARCLAYS S+" & @CRLF & _
"AIX.EG3P UNIX BARCLAYS S+" & @CRLF & _
"AIX.RMWDEV1 UNIX FDCS " & @CRLF & _
"AIX.RMWPROD1 UNIX FDCS " & @CRLF & _
"AIX-EFXWRWCK01 UNIX EQUIFAX EUROPE" & @CRLF & _
"ANB-DRC-CDFDI NT ARAB NATIONAL BANK (ANB) SSL" & @CRLF & _
"APPDGVIRTUAL23F NT LTSB MAIL AND DISTRIBUTION" & @CRLF & _
"APPLCOND MVS CIM ITALIA (FOR BNL)" & @CRLF & _
"APPLGVIRTUAL0FA NT LTSB MAIL AND DISTRIBUTION TLS" & @CRLF & _
"APPLGVIRTUAL191 NT LTSB MAIL AND DISTRIBUTION TLS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")