package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+)\h+(\S+)\h+(\w+(?:\h\w+)*(?:\h*\([^)]+\)(?:\h\w+)?)?)(?:\h{2,}(\S+))?$`)
var str = `SIG.SND.SERV ZOS FD MCA LPAR (MCA - NDMSRV LOCAL)
ADC1 ZOS AMEX SSL
ADEPTRA.GB1.PROD LINUX FICO (ADEPTRA) LTD TLS
ADEPTRA.GB2.CQA LINUX FICO (ADEPTRA) LTD TLS
AIX.EG3C UNIX BARCLAYS S+
AIX.EG3P UNIX BARCLAYS S+
AIX.RMWDEV1 UNIX FDCS
AIX.RMWPROD1 UNIX FDCS
AIX-EFXWRWCK01 UNIX EQUIFAX EUROPE
ANB-DRC-CDFDI NT ARAB NATIONAL BANK (ANB) SSL
APPDGVIRTUAL23F NT LTSB MAIL AND DISTRIBUTION
APPLCOND MVS CIM ITALIA (FOR BNL)
APPLGVIRTUAL0FA NT LTSB MAIL AND DISTRIBUTION TLS
APPLGVIRTUAL191 NT LTSB MAIL AND DISTRIBUTION TLS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}