$re = '/^(?:"[^"]*", ){1}\K"[^"]*"/m';
$str = '"Cafes", "Footwear", "Women\'s fashion"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);