re = /^(?:"[^"]*", ){1}\K"[^"]*"/m
str = '"Cafes", "Footwear", "Women\'s fashion"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end