use strict;
my $str = 'create or replace package body ORA_MTK.Test_package_03 as
procedure do_something (n1 in NUMBER, n2 in out NUMBER,n3 in out NOCOPY NUMBER) as
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
aaa13 ty_base:= new ty_base(participantid => \'a\',clientid => \'1\',price => 3);
begin
aaa11 ty_base := new ty_base();
l_array12 tyt_base := new tyt_base(ty_base(1,2,3));
l_array13 := new tyt_base(ty_base(1,2,3));
aaa13 := new ty_base(participantid => \'a\',clientid => \'1\',price => 3);
aaa14 := new ty_base(participantid => \'a\', -- comment 01
clientid => \'1\' -- comment 01 ; ,
,price => 3);
aaa15 := new ty_base(participantid15 => \'a\', -- comment 01
-- comment 02;
clientid15 => \'1\'
,price15 => 3);
aaa16.xxxx := new ty_base(participantid => \'a\',clientid => \'1\',price => 3);
l_array(l_array.count) := NEW ty_base(participantid => 300,clientid => 2,price => 3);
l_array(l_array.count).xxxx := NEW ty_base(participantid => 300,clientid => 2,price => 3);
"aaa 17" := new ty_base(participantid => \'a\',clientid => \'1\',price => 3);
end do_something;
end Test_package_03';
my $regex = qr`\b([^\s\"]+)(\s+|)\:=\s+new\s+([^(]+)\(([^;\(\)]+)\);`mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}