$re = '/^[0-9.]$/m';
$str = '1,1
,1
,,,,,
1
.
.1
1.1
12
123
..
This is 1,1 and this is 1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);