re = /^[0-9.]$/m
str = '1,1
,1
,,,,,
1
.
.1
1.1
12
123
..
This is 1,1 and this is 1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end