$re = '/^/(?!(about|works|shops))[0-9a-z]{5}/$/m';
$str = '/some1/
/some2/
/about/
/works/
/shops/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);