re = /^\/(?!(about|works|shops))[0-9a-z]{5}\/$/m
str = '/some1/
/some2/
/about/
/works/
/shops/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end