package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z0-9_]+$`)
var str = `NAME
WITH_UNDERSCORE
NO-HYPHEN
NOmIXED
<invalid=chars
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}