$re = '/^[A-Z0-9_]+$/m';
$str = 'NAME
WITH_UNDERSCORE
NO-HYPHEN
NOmIXED
<invalid=chars
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);