using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\A[^\s""'«():])(\S+[ ]{0,1})+([^\s()]\Z)";
string input = @"ООО ""Ромашка"" 1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}