$re = '/(\A[^\s"\'«():])(\S+[ ]{0,1})+([^\s()]\Z)/';
$str = 'ООО "Ромашка" 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);