#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\*](.*)"
Local $sString = "[table]" & @CRLF & _
"[**]header1[||]header2[||]header3[||]...[/**]" & @CRLF & _
"[*]child1.1[|]child1.2[|]child1.3[|]..." & @CRLF & _
"[*]child2.1[|]child2.2[|]child2.3[|]..." & @CRLF & _
"[*]child3.1[|]child3.2[|]child3.3[|]..." & @CRLF & _
"[*]...[|]...[|]...[|]..." & @CRLF & _
"[/table]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")