import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(['\"])((?:(?!(?<!\\\\)\\1).)*+)\\1";
final String string = "val1=\"\"val2>\"2022-11-16 10:19:20\"\n"
+ "val2>\"2022-11-16 10:19:20\"val1=\"\"\n\n"
+ "val1=\"\"val2>\"2022-11-16\\\" 10:19:20\"\n"
+ "val2>'2022-11-16\" 10\\':19:20'val1=\"\"\n\n"
+ "\\'2022-11-16 10:19:20'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}