const regex = /(?<!\\)(['"])((?:(?!(?<!\\)\1).)*+)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)([\'"])((?:(?!(?<!\\\\)\\1).)*+)\\1', 'g')
const str = `val1=""val2>"2022-11-16 10:19:20"
val2>"2022-11-16 10:19:20"val1=""
val1=""val2>"2022-11-16\\" 10:19:20"
val2>'2022-11-16" 10\\':19:20'val1=""
\\'2022-11-16 10:19:20'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}