$re = '/.*\.([^\.]+\.test\.com)$/m';
$str = 'api.api-7-53b34rt.dev1.test.com
api.api-7-53b34rt.dev2.test.com
api.api-7-53b34rt.test1.test.com';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;