// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\.([^\.]+\.test\.com)$").unwrap();
let string = "api.api-7-53b34rt.dev1.test.com
api.api-7-53b34rt.dev2.test.com
api.api-7-53b34rt.test1.test.com";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}