import re
regex = re.compile(r"(?=\w{6,})(?=\w*\d{2})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("bana12\n"
"abc123\n"
"8pass99\n"
"astr1on11aut\n\n"
"banan1\n"
"astronaut\n"
"12345\n"
"1a2bcde")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")