$re = '/^.*?\s.*?[-]/';
$str = '- Italy
- Japan
United States
Africa
Middle - of-words
-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);