re = /^.*?\s.*?[-]/
str = '- Italy
- Japan
United States
Africa
Middle - of-words
-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end