package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#[^\s!@#$%^&*()=+.\/,\[{\]};:'"?><]+`)
var str = `#5g
#321
#dads #fdasfdadf #fdafdsa
#водлфы #jfdslk
#5g ds #5g #fasdf
#你好吗
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}