re = /#[^\s!@#$%^&*()=+.\/,\[{\]};:'"?><]+/
str = '#5g
#321
#dads #fdasfdadf #fdafdsa
#водлфы #jfdslk
#5g ds #5g #fasdf
#你好吗
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end