$re = '/(.*)\[date=([^\[\]]*)?;([^\[\]]*)?](.*)/';
$str = 'Bestellung_[date=DATUM;yyyy-mm-dd]_[dbField=FIRMA1][docNr]_ID_[dbField=ID]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);