// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\[date=([^\[\]]*)?;([^\[\]]*)?](.*)").unwrap();
let string = "Bestellung_[date=DATUM;yyyy-mm-dd]_[dbField=FIRMA1][docNr]_ID_[dbField=ID]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}