const regex = /(?<=client:)\s*([\w\s\.\-]+),\s*([\w\s\.\-]+)\s*_doc/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=client:)\\s*([\\w\\s\\.\\-]+),\\s*([\\w\\s\\.\\-]+)\\s*_doc', 'gmi')
const str = `Client: Doe,John_Doc //true
client: Doe, john_doc //true
client: Doe, john-Peter_doc //true
Client: Dow-Jones, Billy-Ray_doC
CLIENT: Doe, john //false
Client:Doe,John_doc //true
client:doe,john _Doc //true
Client:Dow Jones,Billy ray_doc //True
client: Dow Jones, B.R. _DOC //True`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}