re = /(?<=client:)\s*([\w\s\.\-]+),\s*([\w\s\.\-]+)\s*_doc/mi
str = 'Client: Doe,John_Doc //true
client: Doe, john_doc //true
client: Doe, john-Peter_doc //true
Client: Dow-Jones, Billy-Ray_doC
CLIENT: Doe, john //false
Client:Doe,John_doc //true
client:doe,john _Doc //true
Client:Dow Jones,Billy ray_doc //True
client: Dow Jones, B.R. _DOC //True'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end