#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^REF\*23\*(.+)~"
Local $sString = "REF*0F*452574437~" & @CRLF & _
"REF*1L*627783972~" & @CRLF & _
"REF*23*526344060~" & @CRLF & _
"REF*6O*1024817112~" & @CRLF & _
"DTP*336*D8*20140623~" & @CRLF & _
"DTP*473*D8*20191001~" & @CRLF & _
"DTP*474*D8*20191031~" & @CRLF & _
"DTP*473*D8*20191101~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")