import re
regex = re.compile(r"^REF\*23\*(.+)~", flags=re.MULTILINE)
test_str = ("REF*0F*452574437~\n"
"REF*1L*627783972~\n"
"REF*23*526344060~\n"
"REF*6O*1024817112~\n"
"DTP*336*D8*20140623~\n"
"DTP*473*D8*20191001~\n"
"DTP*474*D8*20191031~\n"
"DTP*473*D8*20191101~")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")