package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)This is what I want to print$`)
var str = `This a line of something I dont need
More of what I dont need
This is what I want to print
This is the pattern I need to find
This is unimportant
So is this
This too
As well as this
This is what I want to print`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}