$re = '/This is what I want to print$/ms';
$str = 'This a line of something I dont need
More of what I dont need
This is what I want to print
This is the pattern I need to find
This is unimportant
So is this
This too
As well as this
This is what I want to print';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);