package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+(?:%|percent\b)`)
var str = `423%
423%:
10percent
10percent:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}