$re = '/\b\d+(?:%|percent\b)/';
$str = '423%
423%:
10percent
10percent:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);