use strict;
my $str = 'Dealer: callawaykid wins 428 chips
Dealer: ** Hand [ 1288159259 ] started **
Dealer: Dealt to board: [ 4h Qh 2c ]
Dealer: Dealt to board: [ 8h ]
Dealer: Dealt to board: [ 6d ]
Dealer: Showdown: Main pot, 380 chips
Dealer: centraliaxxx mucks
Dealer: centraliaxxx wins 380 chips
Dealer: ** Hand [ 1288159639 ] started **';
my $regex = qr/^Dealer:[ \s]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";