import Foundation
let pattern = #"^Dealer:[ \s]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Dealer: callawaykid wins 428 chips
Dealer: ** Hand [ 1288159259 ] started **
Dealer: Dealt to board: [ 4h Qh 2c ]
Dealer: Dealt to board: [ 8h ]
Dealer: Dealt to board: [ 6d ]
Dealer: Showdown: Main pot, 380 chips
Dealer: centraliaxxx mucks
Dealer: centraliaxxx wins 380 chips
Dealer: ** Hand [ 1288159639 ] started **
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)