import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-z]()|\\d()|[A-Z]()|[^\\n\\w]()){8,}(?:\\1\\2(?:\\3|\\4)|\\3\\4(?:\\1|\\2))$";
final String string = "aBc@1234\n"
+ "abcD1234\n"
+ "abc@1234\n"
+ "abcdeFg#xyz\n"
+ "123x56$89\n"
+ "abcdefgh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}