$re = '/^(?:[a-z]()|\d()|[A-Z]()|[^\n\w]()){8,}(?:\1\2(?:\3|\4)|\3\4(?:\1|\2))$/mx';
$str = 'aBc@1234
abcD1234
abc@1234
abcdeFg#xyz
123x56$89
abcdefgh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);