package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<year>\d{4})(?<month>\d{2})(?<day>\d{2})-(?<hour>\d{2})(?<minutes>\d{2})(?<seconds>\d{2}).*$`)
var str = `20230209-165642
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}