re = /^(?<year>\d{4})(?<month>\d{2})(?<day>\d{2})-(?<hour>\d{2})(?<minutes>\d{2})(?<seconds>\d{2}).*$/m
str = '20230209-165642
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end