using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\W\d_])(?:lemon|apple|coconut)(?![^\W\d_])";
string input = @"/var/prj/lemon_123/xyz
/var/prj/123_apple/coconut
/var/prj/lemonade/coconutapple
/var/prj/apple/lemon";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}