$re = '/(?<![^\W\d_])(?:lemon|apple|coconut)(?![^\W\d_])/m';
$str = '/var/prj/lemon_123/xyz
/var/prj/123_apple/coconut
/var/prj/lemonade/coconutapple
/var/prj/apple/lemon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);