re = /\<data\>\s*(?<data>[^<]+)/m
str = '<ID> 100034566 </ID> <data> This consists of DB data </data> <date> the date is 04-03-2019 </data>..........etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end