using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\S*\p{Lu}){2}\S*";
string input = @"eHJHJK
YUIYUI
LkfjkdJkdfj
LLdkjkd
OhdfjhdsjO
LLLuoiu9898
Ohdf&jh/dsjO
auuuu
JJJJJJJJ
YYYY99999
ooooPPPP";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}