$re = '/(?:\S*\p{Lu}){2}\S*/m';
$str = 'eHJHJK
YUIYUI
LkfjkdJkdfj
LLdkjkd
OhdfjhdsjO
LLLuoiu9898
Ohdf&jh/dsjO
auuuu
JJJJJJJJ
YYYY99999
ooooPPPP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);