import re
regex = re.compile(r"(?<=(?!(https*://)*((127)|(192\.168)|(0\.0\.0\.0)))(?:(?:https*://)|^))(?:(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2}))(?=[^\d\s]|$)", flags=re.MULTILINE)
test_str = ("http://127.0.0.1\n"
"127.0.0.1\n"
"http://192.168.0.155\n"
"192.168.0.155\n"
"https://0.0.0.0\n\n"
"25.61.12.6\n"
"http://193.168.0.155\n"
"http://148.251.8.11\n"
"115.148.63.10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")