#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?i)WHERE|AND|OR) \(?([a-zA-Z0-9]+)"
Local $sString = "" & @CRLF & _
" return all strings (a-zA-Z0-9) of any length that" & @CRLF & _
" start right after one of the following expressions: "WHERE ", "AND ", "OR ", "WHERE (", "AND (", "OR (" and" & @CRLF & _
" end right before one of the following expressions: "=", ">", "<", "LIKE", "NOT")" & @CRLF & _
" all these expressions should be case-insensitive." & @CRLF & _
"" & @CRLF & _
"I was playing around with the following online regex-tester: https://www.phpliveregex.com/#tab-preg-match-all. However, the closest I got was this, as I dont know how to get multiple matches:" & @CRLF & _
"" & @CRLF & _
"preg_match_all('/^[where|and|or|\(]* ([a-zA-Z0-1]*)[ |=|<|<=|>|>=|or|in]*.*$/', $input_lines, $output_array);" & @CRLF & _
"" & @CRLF & _
"Some example SQL-queries:" & @CRLF & _
"" & @CRLF & _
" SHOULD RETURN" & @CRLF & _
"WHERE var1=1 AND var2=1 => var1; var2" & @CRLF & _
"WHERE var2 IN (1, 2, 3) OR var3=2 => var2; var3" & @CRLF & _
"WHERE (var4 like '%test%' and var5 NOT LIKE '%test%') => var4; var5" & @CRLF & _
"WHERE var6 = 'test' AnD var7='test2' => var6; var7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")