import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?i)WHERE|AND|OR) \\(?([a-zA-Z0-9]+)";
final String string = "\n"
+ " return all strings (a-zA-Z0-9) of any length that\n"
+ " start right after one of the following expressions: \"WHERE \", \"AND \", \"OR \", \"WHERE (\", \"AND (\", \"OR (\" and\n"
+ " end right before one of the following expressions: \"=\", \">\", \"<\", \"LIKE\", \"NOT\")\n"
+ " all these expressions should be case-insensitive.\n\n"
+ "I was playing around with the following online regex-tester: https://www.phpliveregex.com/#tab-preg-match-all. However, the closest I got was this, as I dont know how to get multiple matches:\n\n"
+ "preg_match_all('/^[where|and|or|\\(]* ([a-zA-Z0-1]*)[ |=|<|<=|>|>=|or|in]*.*$/', $input_lines, $output_array);\n\n"
+ "Some example SQL-queries:\n\n"
+ " SHOULD RETURN\n"
+ "WHERE var1=1 AND var2=1 => var1; var2\n"
+ "WHERE var2 IN (1, 2, 3) OR var3=2 => var2; var3\n"
+ "WHERE (var4 like '%test%' and var5 NOT LIKE '%test%') => var4; var5\n"
+ "WHERE var6 = 'test' AnD var7='test2' => var6; var7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}