$re = '/.+?:not\(.+?\)/m';
$str = '.track a:not(.track-visual)
.track a(.track-visual)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);