re = /.+?:not\(.+?\)/m
str = '.track a:not(.track-visual)
.track a(.track-visual)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end